読者です 読者をやめる 読者になる 読者になる

When it’s ready.

出来るまで出来ない

GAEフレームワークKayの初めの最初

ここ数日悩んでいたKayの起動に関してひとまず決着した感じ。

Port版の2.6や2.5だと、推奨バージョンじゃなかったり、必須モジュールが別パッケージになっていたり、色々大変なのでPort版で動かすのは、ややめんどくさい感じです。

お勧めの構成は、python.orgに上がってるpython2.5.4のdmgを入れるだけのパターン。
それだけで、全くエラーの無い状態でKayを使用する事が出来ます。今まで色々やってたのは何だんだったんだという感じ。

Port版のPythonは、Porticus.appを使ってdeactivateしました。

Kay使うまでのOSX10.5.4での手順

  1. python.orgのpython.2.5.4をDL&install
  2. hg clone https://kay-framework.googlecode.com/hg/ kay-framework
  3. cd kay-framework
  4. less README